返回旧版| 微信建站| 我要建站 | 建站学习 | 加入收藏
DEDECMS当前位置:首页 > cms教程 > 综合cms > DEDECMS > 正文

dede5.8版本下安装插件提示模块中存在恶意代码问题解决

发布时间:2021-09-04 15:02:35   来源:   点击:
dede5.8增加了对上传模块的安全校验,造成模块中含有eval、assert等代码的直接提示存在恶意代码,造成插件无法安装,解决办法:
解决方法:

1、打开/include/dedemodule.class.php
找到以下代码:
  1. if(preg_match("#[^a-z]+(eval|assert)[\s]*[(]#i", $ct) == TRUE) 
  2.  { 
  3.        ShowMsg("你所上传的模块中存在恶意代码!""module_upload.php"); 
  4.         exit(); 
  5.  } 
直接删掉或者注释掉即可

相关栏目
热门文章
最新图文
评论排行
版权所有:郑州腾石网络科技有限公司 备案信息:豫ICP备18019117号-2
站长QQ:2863868475 业务合作咨询:15137100750(同微信)
本站所有投放的广告是有其他网站提供,不代表本站立场,同时网站首页广告位对外出租详情咨询本站站长!同时欢迎广大站长加入个人建站团队
  • 建站客服
  • CMS仿站
  • CMS学习
  • 技术交流群:336572814